Category:Needs Confirmation

From The Forest Wiki
Jump to: navigation, search

The following are pages that have old and outdated information tagged with [confirmation needed]. They need to be updated as of the newest update, Alpha v0.71 (released December 15, 2017).

Pages in category "Needs Confirmation"

The following 6 pages are in this category, out of 6 total.